Instalace nesvobodného ovladače pro grafické karty ATI/AMD

fglrx-legacy pro karty ATI/AMD HD2xxx, HD3xxx a HD4xxx

Množí se případy, že se majitelé starších grafických karet ATI/AMD marně snaží nainstalovat nebo upgradovat oficiální ovladače od tohoto výrobce. Důvodem je to, že v repositářích distribucí jsou většinou ovladače pouze pro novější typy karet. Pokud tedy chcete přejít ze svobodných ovladačů nainstalovaných se systémem a začít používat tyto tzv. nesvobodné ovladače, tak je potřeba nainstalovat pro typy HD 2xxx - HD 4xxx tzv. legacy verzi. Tyto legacy verze jsou vedeny jako oddělená vývojová větev a proto nejsou oficiálně v repositářích Mintu ani Ubuntu. Naštěstí existuje skvělý soukromý zdroj spravovaný člověkem jménem Tomasz Makarewicz, kde jsou tyto verze včetně případných aktualizací.

Jedinou podmínkou funkčnosti fglrx-legacy ovladače je mít nainstalovanou starší verzi Xorg a to verzi 1.12 a nižší (např. Xorg 1.11 v Mintu 13 apod.).

Pokud přecházíte na novější verzi systému bez nové instalace pouze přes upgrade balíčků (Přechod bez DVD) a chcete si ponechat stejnou grafickou kartu, tak je dobré si ponechat starší verzi Xorgu, která je funkční s fglrx-legacy ovladačem tzv. zaholdovat či česky správně zamknout verzi - umí to Synaptic (označit balíček a přes menu Balík vybrat „Zamknout verzi“) i to lze udělat přes terminál (terminálové příkazy pro správu balíčků)

Přidání PPA je velmi jednoduché a je stejné jako u jiných zdrojů PPA tohoto typu:

sudo add-apt-repository ppa:makson96/fglrx

Pak stačí v Synapticu nebo v terminálu obnovit zdroje:

sudo apt-get update

Před instalací se musí odinstalovat všechny předešlé instalace fglrx ovladačů buď přes Synaptic volbou „Úplně odstranit“ nebo přes terminál:

sudo apt-get purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

A poté fglrx-legacy nainstalovat buď přes Synaptic nebo přes terminál:

sudo apt-get install fglrx-legacy

Restartujeme počítač a zkontrolujeme, jestli se vše zobrazuje správně. Funkční 3D akceleraci poznáme podle toho, že nám fungují všechny efekty a ve výpisu níže uvedeného příkazu vidíme grafický ovladač fglrx-legacy:

inxi -G

fglrx pro karty ATI/AMD HD5xxx a vyšší

Pro instalaci nejnovějších ovladačů na nové grafické karty je možno použít více metod (např. stažení ovladače přímo ze stránek výrobce nebo počkat na aktualizace v repositáři apod.), ale jedna je velmi jednoduchá. Přidáme si totiž do systému zdroj PPA, kde nalezneme nové ovladače. Opět je přidání PPA velmi jednoduché a je stejné jako u jiných zdrojů PPA:

sudo add-apt-repository ppa:xorg-edgers/ppa

Pak stačí v Synapticu nebo v terminálu obnovit zdroje:

sudo apt-get update

Opět je lepší před instalací odinstalovat všechny předešlé instalace fglrx ovladačů buď přes Synaptic volbou „Úplně odstranit“ nebo přes terminál:

sudo apt-get purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

A poté již fglrx nainstalovat buď přes Synaptic nebo přes terminál:

sudo apt-get install fglrx

Opět restartujeme počítač a zkontrolujeme, jestli se vše zobrazuje správně. Funkční 3D akceleraci poznáme podle toho, že nám fungují všechny efekty a ve výpisu níže uvedeného příkazu vidíme použitý grafický ovladač fglrx:

inxi -G

Ovladače pro AMD/Intel Hybrid

Tento typ grafické dispozice se týká především notebooků a netbooků. Jde o systém dvou grafických karet, mezi kterými lze přepínat a volit si tak, jakou kartu budeme používat.
Níže uvedený návod NEMUSÍ fungovat na všech zařízeních. Není však v našich silách zpracovávat všechny návody, které s problematikou souvisí a lze je jednoduše nalézt na internetu pomocí vyhledávače. Zvolili jsme tedy ten nejjednodušší postup, který si může vyzkoušet každý bez hlubších znalostí linuxu.

Přidáme si PPA jako u výše uvedených postupů (info o přidávání zdrojů PPA):

sudo add-apt-repository ppa:andrikos/ppa

Raději před instalací odinstalovat všechny předešlé instalace fglrx ovladačů buď přes Synaptic volbou „Úplně odstranit“ nebo přes terminál:

sudo apt-get purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

Pak v Synapticu nebo v terminálu obnovit zdroje:

sudo apt-get update

A poté již fglrx a xserver-xorg-video-intel nainstalovat buď přes Synaptic nebo přes terminál:

sudo apt-get install fglrx xserver-xorg-video-intel

Nakonec zapneme fglrx ovladač:

sudo aticonfig --initial --force

Pokud by nastal problém s fglrx ovladačem, tak lze zkusit nainstalovat ještě update:

sudo apt-get install fglrx-updates

Na závěr bude potřeba restartovat notebook či netbook.

Může se stát, že v Synapticu nebude sofware z nově přidaných PPA zdrojů vidět. Potom je nutné zdroje obnovit kliknutím na tlačítko „Obnovit“




instalace_nesvobodnych_ovladacu_ati-amd.txt · Poslední úprava: 10/11/2016 08:55 (upraveno mimo DokuWiki)